Re: ChangeLog Entry: Saving MUD time

From: Peter Ajamian (
Date: 06/20/01

George Greer wrote:
> I suppose the heartbeat() idea is a good one, more so for crashing than
> copyover.  Copyover would simply restart after saving the time at the end.

What I meant for copyover is that by separating out that bit of code into
its own function it would make it easier to apply that code to a MUD
which uses copyover (or vice-versa) because you can just add a single
line calling the function from inside do_copyover().  The idea of adding
it to heartbeat is strictly for crashing.

In my own MUD (which has copyover) I separated the code out into a
function and I call it from three places, init_game(), heartbeat(), and

Regards, Peter

   | FAQ: |
   | Archives: |

This archive was generated by hypermail 2b30 : 12/05/01 PST