Re: [NEWBIE] spell_level()

From: Shane P. Lee (
Date: 11/04/02

--- Brian <borlick@MINES.EDU> wrote:
>> "Shane P. Lee" wrote:
> > Yes, Zero counts, but the array value should always be one number
> > higher. What you should have is 'chclass[NUM_CLASSES ++]' which
> Um, what?  I'm hoping you mean 'chclass[NUM_CLASSES + 1], because
> attempting to increment a constant does a whole lot of nothing (and
> results in a compilation error).

Yes, that was a typo, I meant [NUM_CLASSES +1].

> > is more portable. On a side note, since 'class' is a reserved
> > keyword for C++, it's something that should be avoided.
> 'class', like all other tokens in C and C++ is unique from any
> combination of it and other characters.  That is, 'chclass' is no
> more
> likely to collide with 'class' than 'rutabaga' and 'Class' are.
> Unless
> you think 'chClass' or 'ch_class' is a bit more readable, there's no
> reason to change this variable name.

He's the one wanting to change from ch_class to class, not me.
CircleMUD used to use 'class' but it was changed to 'ch_class'
around bpl16 or so to make it more compatible.


Do you Yahoo!?
HotJobs - Search new jobs daily now

   | FAQ: |
   | Archives: |
   | Newbie List:   |

This archive was generated by hypermail 2b30 : 06/25/03 PDT