Re: [newbie] [dg scripts] foolish errors and some notes

From: The Fungi (
Date: 06/29/02

On Sat, Jun 29, 2002 at 04:54:56PM +0000, The Fungi wrote:
> I think I've still got some output issues with the triggers
> somewhere because I'm not getting text when they fire whereas I was
> before I fixed the trigedit-related crashes. Maybe I swapped out
> actor/victim descriptors in one of the send_to_char functions. If
> you have a pristine with triggers that fire, upload it and I'll diff
> it against mine to see what's changed.  Otherwise I'll just begin
> checking the suspect functions until I track it down.

I know it's bad form to reply to oneself, so sue me. I've got more
detail... I can set a trigger on a room, object, mobile, what have
you via the usual Oasis commands. In OLC the trigger shows being
set, but it won't fire or show with the stat command after a save to
memory, file or zreset. *However*, upon rebooting the MUD the
triggers work as expected and are visible with stat.

I'm not going to have time to futz with it until later in the day,
but if anyone familiar with DG Scripts source wants to suggest a
starting point, I'm all ears. Obviously the triggers are being saved
and loaded from file properly. I just need to dig through the code
to find which functions are responsible for applying after OLC save
to memory and make sure they look like the ones applying when loaded
from file.

Hopefully I'll upload an updated patch with fixes for the above
problem sometime before my cartoons come on tonight... Heh.
{ IRL(Jeremy_Stanley); PGP(9E8DFF2E4F5995F8FEADDC5829ABF7441FB84657);
SMTP(; IRC(; ICQ(114362511);
AIM(dreadazathoth); YAHOO(crawlingchaoslabs); FINGER(;
MUD(; WWW(; }

   | FAQ: |
   | Archives: |
   | Newbie List:   |

This archive was generated by hypermail 2b30 : 06/25/03 PDT